General http://formmail-maker.com/forum/index.php?p=/categories/general/feed.rss Tue, 19 Sep 17 14:45:27 -0400 General en-CA My form uses security image, and the "Please check the required fields" shows all the time. Why? http://formmail-maker.com/forum/index.php?p=/discussion/168/my-form-uses-security-image-and-the-please-check-the-required-fields-shows-all-the-time.-whys Thu, 30 May 2013 12:54:02 -0400 admin 168@/forum/index.php?p=/discussions You create a form, download the myform.zip file, and upload all php files to your website, but "Please check the required fields" keeps showing up regardless you fill in all required fields. The reason is the PHP session. Your web server's php session config might have some problems. 

To fix this "problem", please try one of the followings :

1) If you know how to change the session config in php.ini, probably the variable session.save_path, then please make sure the folder's permission is writable by web user

2) set the session.save_path to system's temp folder in form.lib.php. just copy the highlight block of code, and paste it to form.lib.php as below:



# PHPFMG_ID:'20110812-77e0'
# Date : 20110812 20:08:13
# Generated By Free PHP Formmail Generator : http://phpfmg.sourceforge.net
# -----------------------------------------------------------------------------
define( 'PAYPAL_ID' , '' ); // Put donation ID here to disable the copyright link

define( 'PHPFMG_TO' , 'abc@test.com' );
define( 'PHPFMG_REDIRECT', '' );

define( 'PHPFMG_ID' , '20110812-77e0' );
define( 'PHPFMG_ROOT_DIR' , dirname(__FILE__) );
define( 'PHPFMG_SAVE_FILE' , PHPFMG_ROOT_DIR . '/form-data-log.php' ); // save submitted data to this file
define( 'PHPFMG_EMAILS_LOGFILE' , PHPFMG_ROOT_DIR . '/email-traffics-log.php' ); // log email traffics to this file
define( 'PHPFMG_ADMIN_URL' , 'admin.php' );

if( !is_writable( ini_get('session.save_path') ) && is_writable(PHPFMG_ROOT_DIR) ){
ini_set( 'session.save_path', PHPFMG_ROOT_DIR );
};

define( 'PHPFMG_SAVE_ATTACHMENTS' , 'Y' );
define( 'PHPFMG_SAVE_ATTACHMENTS_DIR' , PHPFMG_ROOT_DIR . '/uploaded/' );


3) if you can't do 1) method, or the 2) doesn't work for you, then you can login your form admin panel (admin.php), click the "edit form" link to re-generate the form by using reCaptcha method

4) or do not use any catpcha security image method for your form

I suggest you fix the php session problem, otherwise, even the form works, but you won't be able to view or download form data. Because of the php session has problem, it can not keep your login session, so you will be redirected to the login form again.


]]>